Nestopia RGB bug?

Nestopia RGB bug?
by on (#133321)
this hack .........http://www.romhacking.net/hacks/910/

fceux,vnes is ok!

nestopia
Attachment:
11.jpg
11.jpg [ 169.04 KiB | Viewed 2248 times ]
Re: Nestopia RGB bug?
by on (#133323)
Not a bug.

You've somehow turned on Nestopia's 2C03 emulation, which treats the emphasis bits as "set corresponding RGB channel to full brightness".
Re: Nestopia RGB bug?
by on (#133333)
Polite administrative request:

Please stop turning this board into an emulator bug reporting forum. For Nestopia there is an existing ticketing system on github for this exact thing. For other emulators, most of the authors provide an Email address, or a forum of their own. This is not a place to just dump bug reports for individual emulators, as long as those emulators have reachable authors or existing support outlets.

I say this with full acknowledgement that it can be useful for many people to provide insights into something, and say "oh hey MAYBE this is a more widespread emulation bug", but that isn't how this thread (or the other recent thread) is being presented. It's more of "look, something doesn't work, I like taking screenshots and pasting them and then saying bug, clicking Submit, and see what happens".

And when it comes to romhacks, all bets are off. Really. Even I'm responsible for problems with romhacks I've worked on/coded!

TL;DR -- If there's an issue with an emulator you're using, report the bug to the emulator author(s) first, not this board. If the bug is repeatable on multiple emulators (especially those which are known to have good PPU and CPU implementations), and seems to imply something like a mapper quirk, sure, discuss it here and provide full reproduction details. One-liners do not help anyone.
Re: Nestopia RGB bug?
by on (#133340)
I see your point. So what should someone do if he cannot figure out how to sign up and create a problem report through official channels, or if bug reports through official channels go unanswered for months?
Re: Nestopia RGB bug?
by on (#133366)
tepples wrote:
I see your point. So what should someone do if he cannot figure out how to sign up and create a problem report through official channels, or if bug reports through official channels go unanswered for months?

1st question: it's not our problem / has no relevancy to this board, at least not enough to be posting things. Let me rephrase: this forum isn't for direct Nestopia support. I'm pretty hard-assed about this stance, by the way, but I am willing to compromise: what if I added support links to the Emulators page on the wiki (per emulator), i.e. "go here for support/help/etc."?

2nd question: then the user has a multitude of options available to him/her (but I will point out: most people don't read README files any more, unlike us older folks): a) use a different emulator, b) accept the bug as is (esp. if just cosmetic), c) if open-source, look at it and try to figure out the problem + fix it (this is exactly what rdanbrook started doing after Nestopia's author dropped off the face of the planet) -- but I say this with full acknowledgement that not very many end-users can look at code and fix such problems, d) after trying all previous options, maybe post here and say something along the lines of "Hey! I've been trying to track down this weird thing in Nestopia, let me show you what it is. What do you guys think? Emulator bug, game quirk, or what?"

I'm very afraid of making a new/separate board just for emulator support -- that should be handled exclusively by emulator authors.
Re: Nestopia RGB bug?
by on (#133367)
koitsu wrote:
what if I added support links to the Emulators page on the wiki, i.e. go here for support/help/etc.?

Including the preferred support channel would be a good idea. The problem comes when you have to (say) speak Japanese or open a Facebook account or pay or some similarly annoying formality just to report a problem.
Re: Nestopia RGB bug?
by on (#133432)
Do you really want to report such a bug then?
Re: Nestopia RGB bug?
by on (#133447)
Sik wrote:
Do you really want to report such a bug then?

I tested on a RGB machine.
but There seems not to publish nestopia's BUG
Re: Nestopia RGB bug?
by on (#133763)
zxbdragon wrote:
Sik wrote:
Do you really want to report such a bug then?

I tested on a RGB machine.
but There seems not to publish nestopia's BUG

Can you take a picture? Is this a 2C03-based RGB machine? If it is a NESRGB kit machine, you will not see the bug as that is particular to the 2C03 and other similar PPUs.