trouble with inl flasher tool. any suggestions?

This is an archive of a topic from NESdev BBS, taken in mid-October 2019 before a server upgrade.
View original topic
trouble with inl flasher tool. any suggestions?
by on (#238872)
I'm using an oct 2014 v1.4 INL retro dumper board.
the firmware is updated to 2.1.x in order to flash newer cartridges, which according to documentation should be working perfectly with all previous versions of the flasher board.

this also means i need to use the new flash tool; inlretro.exe.

the whole thing is downloaded from the gitlab days ago.

the file to flash is placed in the host folder.

my command:
inlretro.exe -s scripts\inlretro2.lua -c NES -m mapper30v2 -x 512 -p myGame.nes

my error: inlprog.c:372: errno: No such file or directory

the file indeed exists and i've tripple checked my path.

subsequently but probably of lesser importance, it doesn't find ignore/chramdump.bin and this directory and binary does not indeed exist... i'm half-assuming these might be program generated, if only the handover to the lua had worked.

running command prompt as administrator simply denies access to the program.
changing ownership to administrator doesn't change that, or any other thing.. except for denying access from user accounts, too.

just as a dumb check, i tried an absolute path to the .lua file. no dice.

what might i be doing wrong?

the relevant c code, i think. i can't read c but it looks like it just checks if we're using an option or default and then checks this against something called lua_pcall... either way, neither option nor if i rename the relevant c file to the default name works.

char *DEFAULT_SCRIPT = "scripts/inlretro.lua";
   char *script = DEFAULT_SCRIPT;
   if (strlen(opts->lua_filename)) {
      script = opts->lua_filename;
   check(!(luaL_loadfile(L, script) || lua_pcall(L, 0, 0, 0)),
         "cannot run config. file: %s", lua_tostring(L, -1));
Re: trouble with inl flasher tool. any suggestions?
by on (#238874)
Paul kindly helped me solve this:

this version of the mapper 30 .lua works, whereas the one currently on gitlab seems not to, at least with my particular setup. If you have an old pre- 2.0 board (using an AVR), this might go for you too. ... 2.lua?dl=0